a kz750e that wont accelerate - Kawasaki Forums: Kawasaki Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-23-2010, 12:06 PM Thread Starter
Junior Member
 
Join Date: May 2010
Location: Olathe ,Ks
Posts: 3
Question a kz750e that wont accelerate

i have a 1981 kz750e and when i drive it will only get to 55mph. after that i can hold it down full throttle and the rpms wont get above 5000. i have been slowly fixing it up but i am at a loss when it comes to this. and i have to have the choke on all the way just for the bike to run an idle speed of 2000 if it drops below that it dies on me. it gets only like 15 mpg which it should get like 53 according to the manual. i normally work on cars and am new to bike so any help would be appreciated.
geoking66062 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-23-2010, 07:43 PM
Junior Member
 
Join Date: May 2010
Posts: 4
KZ750 E won't go

Without knowing more I would say check on the float level being to high and a very dirty or completely clogged air filter. Also check that your exhaust is clear and not clogged/ blocked up.
lpscruggs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forums: Kawasaki Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome