Kawasaki Forums: Kawasaki Motorcycle Forum - View Single Post - '03 ZR-7 engine is very upset
View Single Post
post #1 of (permalink) Old 08-13-2018, 06:43 PM Thread Starter
Logan Cormier
Junior Member
 
Join Date: Aug 2018
Posts: 2
'03 ZR-7 engine is very upset

Got an inline-4, oil cooled Kawi a couple weeks back. Was fairly well cared for. Light issues with the carbs - probably a slightly sticky float valve. Previous owner had no significant problems and was diligent with maintenance. Noticed a little ticking a week into riding, but not severe. One of the exhaust pipes isn't discolored from heat like the other 3. Was suspicious I wasn't getting quiiite the MPG or performance I should. Second week riding, after a long ride largely through cities (toasty engine, running fine), left it off for ~30 mins and had a looot of trouble getting it to start and not die idling. Barely made it home; Would die out if given more than 1/3 throttle, and had to adjust idle significantly higher to keep it from dying. Checked oil, which had just been changed a couple weeks back: Dirty as ****. Previous oil changes were completely clean, but changed early anyway.

What should I check for when I open it up?
How much can I accomplish myself through research and careful work?


Side question: Would it be possible or realistic to rip an EFI system off a junked 4 cylinder bike and install it on my carbureted inline 4?

Any suggestions appreciated. Thanks.
Logan Cormier is offline  
 
 
For the best viewing experience please update your browser to Google Chrome