Pog - Kawasaki Forums: Kawasaki Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-11-2009, 01:34 PM Thread Starter
Junior Member
 
SgtWilliam's Avatar
 
Join Date: Sep 2009
Posts: 5
Pog

Recently my 97 KW 1500 classic had both oil/water light come on. Then started "tapping" in front. I've been told that KW's "plastic oil gear" is the problem and that they are changing it for free regardless of year, does anyone know if that's true or if not, how much it'd cost to fix that problem? Thanks all and stay safe.
SgtWilliam is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forums: Kawasaki Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome