Brake problems - Kawasaki Forums: Kawasaki Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-12-2012, 04:28 PM Thread Starter
Junior Member
 
Join Date: Aug 2012
Posts: 2
Brake problems

Ok I took off my stock OEM stock clutch and Brake handles. Put some new Switch Blade types on it. They went on perfectly now when I took my bike down the road and something went wrong. I was going about 35 or so and the front wheel locked up on me. Let me explain the caliper grabbed the rotor and stuck to it. Can anyone answer this question. Now when I put the new handles on it should I have bleeded the front brake after I installed them. B/C now let me also say after I installed the brake handle it was a little stiff. Was that my warning sign to bleed the brakes or what help please?
Andre1976 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forums: Kawasaki Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome