2009 Vulcan 1700 air shocks - Kawasaki Forums: Kawasaki Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-15-2015, 04:28 PM Thread Starter
Junior Member
 
Join Date: Jun 2015
Posts: 4
2009 Vulcan 1700 air shocks

The shocks used to hold air well. However, this summer they seem to be losing air overnight. One is worse than the other. I tried tightening the valve stem. This worked or so I thought. A couple days later same problem. Any suggestions?
oldncrzy is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-17-2015, 03:07 AM
Junior Member
 
carbon90's Avatar
 
Join Date: Mar 2014
Location: FL
Posts: 29
Sounds a leaking to me. My uncle almost on the same boat on his Nomad aside from the shocks losing air like every two days, have his mechanic done 35psi but still the same problem. He end up replacing them. Do you have hand pump? Fox's is a good one.
carbon90 is offline  
post #3 of 3 (permalink) Old 09-17-2015, 03:00 PM Thread Starter
Junior Member
 
Join Date: Jun 2015
Posts: 4
I am hoping it is the air valve. I took both out and cleaned them. I also bought some spares. So far this seems to be working. I will monitor the air pressure. I do have a proper pump/gauge for shocks from progressive shocks. Thanks for your response. I hope I can avoid the cost of new shocks but we'll see.
oldncrzy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forums: Kawasaki Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome