Kawasaki Forums: Kawasaki Motorcycle Forum - Reply to Topic
Thread: Klx300r weird Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Forums: Kawasaki Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-12-2010 11:53 PM
codyklx300r
Klx300r weird

Just got an 05 KLX300r. It was running good. Then just before i went on a trip i took the but plug and the air box cover off. It was running a little ruff but not to bad so i went on the trip anyways ran ok until i got to high elevation arounrd 7000ft to 8500ft. Then started running really ruff, falls on its face when i juice it, hesitates, back fires every onces in a while. I figured it was just jetting. Drove it back to town around 2700ft. Next week took it for a quick ride around my naborhood still running rough same stuff going on??? So i put the air box cover back on and the butt plug back in took it for a short ride still ran rough. I noticed a black soot build up on the rear fender?? Any ideas? I was gonna just rejet it but the stock jet is 128 that should be ok at 2700ft. Im lost don't know were i should start. Any help would be much apreciated Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome