Kawasaki Forums: Kawasaki Motorcycle Forum - Reply to Topic
Thread: '03 ZR-7 engine is very upset Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Forums: Kawasaki Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-13-2018 06:36 PM
Logan Cormier
'03 ZR-7 engine is very upset

Got an inline-4, oil cooled Kawi a couple weeks back. Was fairly well cared for. Light issues with the carbs - probably a slightly sticky float valve. Previous owner had no significant problems and was diligent with maintenance. Noticed a little ticking a week into riding, but not severe. One of the exhaust pipes isn't discolored from heat like the other 3. Was suspicious I wasn't getting quiiite the MPG or performance I should. Second week riding, after a long ride largely through cities (toasty engine, running fine), left it off for ~30 mins and had a looot of trouble getting it to start and not die idling. Barely made it home; Would die out if given more than 1/3 throttle, and had to adjust idle significantly higher to keep it from dying. Checked oil, which had just been changed a couple weeks back: Dirty as ****. Previous oil changes were completely clean, but changed early anyway.

What should I check for when I open it up?
How much can I accomplish myself through research and careful work?


Side question: Would it be possible or realistic to rip an EFI system off a junked 4 cylinder bike and install it on my carbureted inline 4?

Any suggestions appreciated. Thanks.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome